Engine Ticking

Discussion in 'Challenger R/T Engine and Performance Modifcations' started by Red, Jul 28, 2016.

  1. Red

    Red New Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Jul 28, 2016
    I've read all of the post about the "ticking" and I've had the dealership look at it & I get the same response as everyone else...... "everything sounds good and normal". I'm like "OKAY"..... not sure it is but whatever. I have a 2013 Dodge Challenger R/T & I bought it used this past February (only had 25K miles) and it now has 31K miles.
    So I took it to an independent mechanic (certified) and he could hear it but couldn't figure out where it is coming from. Well now it not only has the ticking but has a vibration when you get it over 50 mph. I just replaced the tires. I have it scheduled to go back to the independent mechanic this Monday.
    Any suggestions or helpful ideas that I can relay to him. I love my care but having second thoughts about keeping it.

    Thank you.
     
  2. SRT-Tom

    SRT-Tom Full Access Member

    Posts:
    2,145
    Likes Received:
    119
    Joined:
    Oct 2, 2011
    Location:
    southern New Jersey
    I have a 6.1 engine and never experienced the Hemi tick. I, however, have used Mobil 1 full synthetic oil, from day one. I suggest that you give it a try.
     
    IntimidatorRT likes this.
  3. Wizard of Iz

    Wizard of Iz Full Access Member

    Posts:
    133
    Likes Received:
    21
    Joined:
    Jan 30, 2015
    Location:
    Jacksonville, Florida
    My wife had an '07 Charger R/T with the 5.7 Hemi that did not tick. And her '13 Charger R/T with the 5.7 Hemi does not tick. Both were purchased new and both had Mobil1 5W-20 from about 1,000 miles on.

    And, my '11 Challenger R/T with the 5.7 Hemi did not tick. I bought it in 2013 with just 11,000 miles and from that time on, it also primarily had Mobil1 5W-20. The one oil change that I tried Pennzoil saw the oil monitor call for an oil change much quicker.

    Like Tom said.....try some Mobil1 Full Synthetic. Just be aware that it doesn't meet FCA's standards


    Sent from my iPad using Tapatalk
     
  4. michael_terrell_

    michael_terrell_ Member

    Posts:
    12
    Likes Received:
    3
    Joined:
    Jul 31, 2016
    Location:
    Virginia
    I have a 2015 Challenger Rt with 5.7 she has about 500 miles on her now.I notice the tick when I first start and not Everytime . after a few seconds of running goes away.I thought wow that oil is draining back down to the oil pan.Because sounds like a dry lifter tick when oil reaches top of the motor the tick goes away. So a different oil or anti drain back oil filter would help.

    Sent from my XT1585 using Tapatalk
     
  5. SRT-Tom

    SRT-Tom Full Access Member

    Posts:
    2,145
    Likes Received:
    119
    Joined:
    Oct 2, 2011
    Location:
    southern New Jersey
    The brand of oil recommended by car companies is based on business relationships. Previously, Chrysler had an arrangement with Mobil to recommend its oils. In fact, the brand logo was imprinted on the oil cap. Now, FCA has a similar arrangement with Pennzoil.

    The key to acceptable oil is the API service symbol on the bottle or jug. Read the following:

    Learn About Motor Oil Standards : Motor Oil Matters: Motor Oil Matters
     
  6. Wizard of Iz

    Wizard of Iz Full Access Member

    Posts:
    133
    Likes Received:
    21
    Joined:
    Jan 30, 2015
    Location:
    Jacksonville, Florida
    Like so many things in life ..... follow the money.

    BTW .... the lesser- quality Mobil Super 5W-20 (compared to Mobil1 Full Synthetic) does meet the spec for the 2011 Hemi 5.7.

    Many GM vehicles also used to ship with Mobil1 Full Synthetic from the factory. My '05 GTO also had the Mobil1 logo on the cap. However, my '16 Chevy SS shipped with a synthetic blend that meets GM's Dexos spec. So, at my first opportunity - about 2200 miles - I changed it to Mobil1 Extended Performance.
     
  7. ZEN357

    ZEN357 Full Access Member

    Posts:
    123
    Likes Received:
    15
    Joined:
    Feb 14, 2018
    Location:
    Wheeling, WV
    I have a 2016 R/T with no tick but only 1000 miles on it. I have a 2006 300C with the 5.7 in it and it ticks but my dealership said it was nothing to worry about.
     

Share This Page