Starter heat shield missing nut??

Discussion in 'Challenger HellCat Forum Engine & Performance' started by 2017 Redline HC, Feb 20, 2021.

  1. 2017 Redline HC

    2017 Redline HC 2017 Redline HC

    Posts:
    916
    Likes Received:
    221
    Joined:
    Apr 18, 2019
    Location:
    Southern Ontario
    While working under the car I noticed what looked to be a missing fastener to hold the heat shield to the starter. I took 2 rubber pluming washers with a stainless washer and stainless M5 nyloc nut and snugged it up. I assumed this would be a possible rattle in the future. I have found out the nut was not missing and that the stud just positions the heat shield....just doesn’t make sense to me.:sad72:
    Below is before and after.

    4BD62F87-77F7-48D4-9147-7F2F7C21E29D.jpeg FDCE67CB-F827-4332-A5F6-DE9E4E4F47CA.jpeg
     
    Cloverdale likes this.
  2. Katshot

    Katshot Full Access Member

    Posts:
    1,046
    Likes Received:
    249
    Joined:
    Mar 28, 2020
    Location:
    Florida
    I would’ve thought the same.
     
  3. B5blueRT

    B5blueRT Full Access Member

    Posts:
    597
    Likes Received:
    212
    Joined:
    Sep 30, 2018
    Location:
    Broadview Hts., Ohio
    You know you wouldn't have these problems if you just stop looking for them. ;)
     
    Cloverdale likes this.
  4. Katshot

    Katshot Full Access Member

    Posts:
    1,046
    Likes Received:
    249
    Joined:
    Mar 28, 2020
    Location:
    Florida
    LOL! When you’re right, you’re right!
     
    IntimidatorRT likes this.